求 机构通道公式 能用在通达信的 谢谢 急盼

N:=102;
M:=9;
AA:=MA((2*CLOSE+HIGH+LOW)/4,5);
通道1:AA*N/100;
通道2:AA*(200-N)/100;
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
通道3:(1+M/100)*DD;
通道4:(1-M/100)*DD;
RSV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
K:=SMA(RSV,5,1);
D:=SMA(K,5,1);
J:=3*K-2*D;
X:=REF(J,1)<10 AND H>REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);
STICKLINE(X,L ,L,20,0),COLOR008888;
STICKLINE(X,L ,H,0,0),COLORFF00FF;
STICKLINE(X,C ,O,5,0),COLORFF00FF;
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,3);
DRAWTEXT(CROSS(BIAS,乖离) AND 乖离<-9,C,'---------BIAS底买'),COLORWHITE;
DRAWTEXT(CROSS(BIAS,乖离) AND 乖离>3,C,'---------BIAS顶'),COLORWHITE;
S下:=HHV(MA(HIGH,2),2),COLORGREEN,LINETHICK0;
S上:=LLV(MA(HIGH,2),1),COLORRED,LINETHICK0;
SPPP:=-(S上-S下)/REF(C,1)*100;
SPTEM1:=(MIN(O,C)-L)/(H-L)*100;
SPTEM2:=(H-MAX(O,C))/(H-L)*100;
SPTEM3:=(C-O)/(H-L)*100;
SKJ1:=(SPTEM3>49 AND SPTEM1>0.3*SPTEM2) OR SPTEM3>80;
SKJ2:=(SPTEM3<=49 AND SPTEM3>20 AND SPTEM1>SPTEM2);
SKJ3:=(SPTEM3<=20 AND SPTEM3>-20 AND SPTEM1>1.2*SPTEM2);
SKJ4:=(SPTEM3<-20 AND SPTEM3>-40 AND SPTEM1>2*SPTEM2);
SKJ:=(SKJ1 OR SKJ2 OR SKJ3 OR SKJ4) AND (SPPP>2 OR REF(SPPP,1)>2 );
短买:=IF(SUM(SPPP>0,5)=5 AND SUM(SKJ>0,5)=0,5*(SKJ1 OR SKJ2 OR SKJ3 OR SKJ4),5*SKJ),COLORRED;
DRAWTEXT(短买,L,'↖短买'),COLORWHITE;
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),
EMA8,'∠45'),COLORWHITE;
STICKLINE(C>=COST(50)AND C<=COST(58)AND C>O,O,C,5,0),COLORRED;
STICKLINE(C>=COST(97)AND C<=COST(100)AND C>O,O,C,5,0),COLORWHITE;
DRAWTEXT(C>=COST(97)AND C<=COST(100) AND C>O,C,'-->97%'),COLORRED;
DRAWTEXT(C>=COST(50)AND C<=COST(58) AND C>O,C,'--50%'),COLORYELLOW;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;
买入线:=IF(CROSS(RSI1,20),100,0);
DRAWTEXT(买入线,L,'←RSI底'), COLORRED ;
买出线:=IF(CROSS(RSI1,80),100,0);
DRAWTEXT(买出线,H,'←RSI1顶'),COLORCYAN;
DRAWICON(FILTER(CROSS(WR,(0 - 81)),10),L,4);
DRAWICON(FILTER(CROSS((0 -19),WR),10),H,5);
DRAWTEXT(FILTER(CROSS(WR,(0 - 81)),21),L,'威廉买'),COLORRED;
DRAWTEXT(FILTER(CROSS(0 -19,WR),21),H,'威廉卖'),COLORGREEN;
TYP := (HIGH + LOW + CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
买入线1:=IF(CROSS(CCI,-160),100,0);
DRAWTEXT(买入线1,L,'←CCI底'),COLOR0099FF ;
买出线1:=IF(CROSS(CCI,200),100,0);
DRAWTEXT(买出线1,H,'←CCI顶'),COLORYELLOW ;
VAR3:=LLV(LOW,5)=LLV(LOW,45) AND CLOSE>=OPEN*1.04;
VAR4:=CLOSE>(REF(HIGH,1)+REF(LOW,1))/2;
VAR5:=VAR3 AND VAR4;
DRAWTEXT(VAR5,LOW,'★ '),COLORYELLOW , ;
极品底:=IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,50,0),COLORWHITE;
DRAWTEXT(极品底=50,LOW,'★ ');
DRAWTEXT(V>=REF(V*1.88,1) AND C>O AND C>REF(C,1),O,'←---突量----------------------------------'),COLORYELLOW;
DRAWTEXT(V>=REF(V*1.88,1) AND C<O AND C<REF(C,1),O,'←---跌量---------------------'),COLORFFFF33;
DRAWTEXT(LLV(VOL,13)=VOL AND C>=REF(C,1),O,'缩量'),COLORYELLOW;
AA0:=SUMBARS(VOL,CAPITAL);
DRAWTEXT(IF(CAPITAL=0,AMOUNT=LLV(AMOUNT,34),VOL<MA(VOL,AA0)/3),L,'地量'),COLORMAGENTA;
A31:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
A41:=SMA(A31,3,1);
A5:=SMA(A41,3,1);
A6:=3*A41-2*A5;
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
DRAWTEXT(FILTER(买=1,5),LOW-0.05,'↖买进'),COLORYELLOW;
STICKLINE(买,OPEN,CLOSE,2,0),COLORYELLOW;
RSV1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K1:=SMA(RSV1,3,1);
D1:=SMA(K1,3,1);
J1:=3*K-2*D1;
X7:=LLV(J1,2)=LLV(J1,8);
主力:=EMA( (CLOSE-MA(CLOSE,3))/MA(CLOSE,3),2);
散户:=EMA( (CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7);
DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<20,LOW,'.雨滴'),COLORFF00FF;
DRAWTEXT(CROSS(主力,散户) AND 主力<0 AND 散户<0,LOW,'.见底'),COLORRED;
LC1:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC1),0),3,1) / SMA(ABS((CLOSE - LC1)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'底背离'),COLORA6E500;
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'顶背离'),COLOR1880FF;...

怎样在通达信软件里添加动力线指标

通达信导入方法:
A:源码导入
1、把要导入的公式(源码)复制下来:方法是用左键先把源码变蓝,之后点右键,点复制;
2、进入主界面,即K线图模式,同时按住CTRL+F,出现公式管理器-->用鼠标左键单击任何一个公式组的名称(选择技术指标公式或者条件选股公式)-->单击其他-->点新建公式-->在出现的公式编辑区的下面的空白处,把刚拷的源码粘贴上,将公式名称复制后粘贴到公式名称栏-->确定-->退出;
3.如有参数的,如:N 1 100 15 之类,则需将这类数据填充到参数表中;
B:文件指标导入:
1,先把指标文件复制到桌面(或者你知道的路径),
2,打开通达信,按CTRL+F打开公式管理器点击“导入”按钮“,
3,找到桌面上要导入的公式选中”公式“后单击左键,后点击“打开”,
4,把“+”号单击展开,在公式名前的空方框里单击成“勾选”后,在点击下方的“确认”。
5,输入指标名称,回车即可。
图例:http://www.gupang.com/201006/062423462010.html

百度知道股票内容管理团队队员为您答复。回答完毕!...

机构探测器中的AI机构活跃度是什么意思?

AI机构活跃度。适用于沪深A股,可使用周期:日线,周线,月线(这个指标源于金融大师PC端,这次增加到了手机),指标中有3条划分线:大牛线:表明短期有多支一线强势机构参与操作,有成为大牛实力强势线:说明个股有强势机构操作生命线:低于生命线时,个股缺乏机构操作...

谁有同花顺ai机构动力&意愿指标公式通达信版

LC:=REF(CLOSE,1);
RSI5:=(SMA(MAX(CLOSE-LC,0),3,1))/(SMA(ABS(CLOSE-LC),3,1))*100;
WR10:=100*(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3));
活跃度:RSI5-WR10,LINETHICK0,COLORFFFF00;
STICKLINE(活跃度>0,0,活跃度,3,1),COLORFF00FF;
STICKLINE(活跃度>68 AND 活跃度<78,0,活跃度,2,0),COLORFFFF00;
STICKLINE(活跃度>78,0,活跃度,2,0),COLOR00FFFF;
SC:100*(CLOSE-MA(CLOSE,20)),LINETHICK2,COLORRED;
MAO:EMA(SC,6),LINETHICK1,COLORGREEN;
80,POINTDOT,COLOR00FF00;
-100,POINTDOT,COLORFFFF00;...

求设计一个通达信公式,在20周期内出现两个低点,但是最后一个低点不低于前一个低点

A:=COUNT(ZIG(3,5),20)=2;
B:=BARSSINCE(ZIG(3,5));
D:=REF(C,B)>LLV(C,20);
E:=C>REF(C,B) ;
A AND D AND E;...

请高手编个通达信用股价站上20日均线并且20日均线向上的选股公式。

CROSS(C,MA(C,20)) AND MA(C,20)>REF(MA(C,20),1);...